[解決済み]VGA(XGA1024x768),SDカードブートで、FedoraのXを立ち上げたい

ホーム フォーラム一覧 Cubieboard [解決済み]VGA(XGA1024x768),SDカードブートで、FedoraのXを立ち上げたい

タグ: 

This topic contains 3件の返信, has 2件の返信, and was last updated by cubie管理人 cubie管理人 4 年 3 ヶ月前.

4件の投稿を表示中 - 1件目から 4件目 (全4件中)
  • 投稿者
    投稿
  • #601

    fumiyasu
    参加者

    XGAのディスプレイしなら余っている、他の20インチディスプレイではHDMI-DVIのケーブルでは動かないということで、Cubietruc得意のVGAで立ち上げるしかありません。 NANDのAndroid,SDカードCubieは問題なく立ち上がり、CubieはXで日本語環境まで整いました。 さて、本命はUbuntuとFedoraで、今のところ、LbuntuはブートはできてもXが立ち上がらない、テキストコンソールは動き、startXでログを見ても特にエラーもなくXサーバ停止。Fedoraはブートができない(止まる)、VGAの設定はuEnv.txtを
    disp.screen0_output_type=4 disp.screen0_output_mode=1024×768
    として、さらに、(よくわかならいのですが,念のため)script.binをfexにして output_type=4にパッチし元に戻します。
     たぶん、VGAまでデバッグできていないのだろう、時間が解決するだろうとは思ひ増すが。HMDIのディスプレーを買っても置くところがないので、何か良い知恵はないでしょうか。

    • This topic was modified 4 年 3 ヶ月前 by cubie管理人 cubie管理人. Reason: 解決済み
    #607
    cubie管理人
    cubie管理人
    傍観者

    こんにちは、管理人です。

    Fedoraのインストールについて、下記の手順をお試しいただけますでしょうか?

    http://docs.cubieboard.org/tutorials/ct1/installation/cb3_fedora19_r3_sd_card_installation

    こちらで確認したところ、正常にVGA出力のXが立ち上げました。
    VGA出力時のuEnv.txtは下記になります:
    console=tty0
    loglevel=5
    root=/dev/mmcblk0p3 ro rootwait rootfstype=ext4
    extraargs=console=ttyS0,115200 disp.screen0_output_type=4 disp.screen0_output_mode=1024×768 sunxi_g2d_mem_reserve=0 sunxi_ve_mem_reserve=0 sunxi_fb_mem_reserve=20 sunxi_no_mali_mem_reserve

    Lubuntuについて、Desktop版やSever版が色々ありますが、具体的にどのイメージと手順を使っていますでしょうか?こちらの手順をお試されましたでしょうか?

    http://docs.cubieboard.org/tutorials/ct1/installation/install_lubuntu_desktop_server_to_sd_card

    ぜひ皆様で知恵を出し合いましょう。
    以上、ご確認のほどよろしくお願いします。

    #616

    fumiyasu
    参加者

    fumiyasuです。貴重なテスト結果ありがとうございます。(このuEnv.txtはテストしたことがあります、他では動くという事実がキーで)これで、考えていた仮設をどうしてもテストしたくなり、テストの結果、Xが立ち上がりました。
    原因は、先のスレッドのNANDが壊れたという話の解決策の use_nandが原因で
    これをゼロにすると、VGAが即動きました。当方のボードも当初、訳の分からない内に、NANDが同じように(プログレシブバーもどきに)壊れてしまいましたが
    Cubieは動いたので、影響ないのだろうと思っていました。VGAに影響があったんですね、まだまだ、shutdownできないなどなど怪しげな現象が出てきますが、
    疲れたので、(Fedoraが動けば慣れてないdebian系の勉強をしなくてもいいので)休憩させてもらいます。
    このフォーラムは,知恵の宝庫で、有り難くおもっています。

    なお,今回のテストは Fedora20-XFCE 前回は ご指摘のFedora19 です.
    ついでに、VGAの私のテスト方法ですが、sceen0_output関係を何もパッチしなければ、ボードにVGAをつながなくてもFedoraは動き出します(多分HDMIで)。これがインストールは正常という証拠になり、その後で,パッチし、VGAをつながなくてもだめなら即止り、OKなら動き始めます。

    #619
    cubie管理人
    cubie管理人
    傍観者

    fumiyasu様
    了解しました。
    ご報告いただき、ありがとうございます。

4件の投稿を表示中 - 1件目から 4件目 (全4件中)

このトピックに返信するにはログインしてください。